Analytics are not loading
Incident Report for Justuno
Resolved
This incident has been resolved
Posted Feb 24, 2020 - 12:17 CST
Investigating
We are currently investigating why analytics are not loading in our dashboard
Posted Feb 24, 2020 - 11:38 CST
This incident affected: Management Portal and Analytics.