Justuno Platform Offline
Incident Report for Justuno
Resolved
All services are back up and running
Posted 4 months ago. Jun 16, 2017 - 11:24 CDT
Identified
DB in recovery mode from an outage. Expected to be back online at 9:30am PST
Posted 4 months ago. Jun 16, 2017 - 10:17 CDT